Ubuntu Server Raid 1 Plattentausch

espeichert. Dazu waren bisher 2 * Samsung 320GB SATA Platten eingbaut die per Linux Software Raid gespiegelt sind (Level 1). Nachdem die Kapatität langsam dem Ende zugeht und die Platten bereits 3 Jahre auf dem Buckel haben, habe ich mich zu 750 GB Seagate 24/7 Modellen entschieden.

Meine Vorgehensweise habe ich hier aufgeführt. ACHTUNG: Während dieses Vorgangs besteht natürlich keine doppelte Datensicherheit für das Raid 1 da nur eine der beiden Platten aktiv ist. Im Falle eines Fehlers hat man aber eine vollständige „Kopie“ des Laufwerks (ausgebaut)

 

     

  1. Server herunterfahren
  2.  

  3. Eine der beiden bestehenden Raid Platten ausbauen und stattdessen eine der neuen Platten einbauen
  4.  

  5. Server hochfahren (bei karmic wurde das degraded Raid 1 nicht automatisch gestartet, hierzu habe ich „mdadm –assemble –run /dev/md0 /dev/sda1“ verwendet)
  6.  

  7. mit fdisk auf der neuen Platte die Raid Partition(en) erstellen und den Typ „fd“ nicht vergessen
  8.  

  9. Ein neues Raid mit der neuen Platte bauen und eine der beiden Member als missing angeben:
    mdadm --create /dev/md1 --level 1 --raid-devices=2 missing /dev/sdb1
  10.  

  11. Nun per rsync oder cp oder wie auch immer die Daten von der alten Platte auf die neue kopieren/schieben
  12.  

  13. Server herunterfahren
  14.  

  15. Die alte Platte ausbauen und die 2te neue Platte hinzufügen
  16.  

  17. Server hochfahren und das Raid „reparieren“ („sfdisk -d /dev/sda |sfdisk /dev/sdb“ um die Partitiontabelle von sda auf sdb zu übertragen und „mdadm –assemble –run /dev/md0 /dev/sda1 /dev/sdb1“ verwendet)
  18.  

  19. Dann kann unter /proc/mdstat der Fortschritt des syncs betrachten („watch cat /proc/mdstat“ zeigt die Ausgabe alle 2 s). Man kann während des syncs schon auf die Daten zugreife, sollte das jedoch zumindest schreibend unterlassen:

    md0 : active raid1 sda1[2] sdb1[0]

    732571904 blocks [2/1] [U_]

    [==>………………]  recovery = 12.8% (94198720/732571904) finish=206.3min speed=51553K/sec

     

  20.  

  21. THAT’s IT xD
  22.  

DVB-S2 mit easyVDR 0.7.10 (BETA!)

Nachdem ich kürzlich eine Mystique Satix DVB-S2 samt CI erworben habe, stand heute der Umbau des VDR auf HD Input an. Die Ausgabe wir die ganze Zeit schon auf 1080 hochgerechnet.
(Die komplette Hardwareliste siehe #1)

Hier die Schritte die nach der Basisinstallation der Beta nötig waren:

  • s2-liblianin Treiber installieren
  • Alternativ: aktualisierten v4l Treiber installieren
    #

  • Meine Soundkarte hat per SPDIF nur Dolby Digital an meinen Surround Receiver ausgegeben, siehe unten. (siehe #2)
  •  

  • lircd.conf aus meinem alten System kopiert (siehe HIER)
  • Nebenbei fragte mich die Setup Prozedur erstmals nach VDPAU (ich denke da eine passende GraKa gefunden wurde) und aktivierte dies automatisch ”;-)”

     

    Hardware Konfiguration Konfiguration:

     

    Mainboard: ASRock P4 dual 915GL
    CPU: Intel(R) Core(TM)2 6300 @ 1.86GHz
    Speicher: 4GB (waren noch übrig, Board erkennt jedoch nur 3200MB, mir wurscht)
    Festplatte 1 (Boot): Hama SSD 40GB (MTRON MSD-SATA3035)
    Festplatte 2 (Video): NFS Mount von Ubuntu 9.10 Server (–> 2* 320GB Seagate als Raid 1)
    Grafikkarte: Geforce 9600GT
    DVB: Mystique Satix DVB-S2 (KNC ONE) mit CI
    Sound (#2):

     

    Obligatorisches vorausgehendes Alsamixer unmuten brachte nichts, die Korrekten Kanäle für SPDIF waren bereits aktiv. Sound funktionierte, wenn der Sender “Dolby Digital” anbot. Stereo war leider Stille angesagt.

     

    Die passende Lösung (zumindest für mich) habe ich hier gefunden:

     

    http://www.vdr-portal.de/board/thread.php?threadid=71413

     

    In der Datei..

     

    ~/.xine/config_xineliboutput

     

    …folgende Zeile(n) ergänzen:

     

    # device used for stereo output
    # string, default: plug:front:default
    audio.device.alsa_front_device:plug:iec958

     

    Nachdem das System nun soweit läuft…Fazit:

     

    Der WAF Faktor ist akzeptabel wobei mir die neuen Treiber bzw. die Sat Karte noch nicht ganz symphatisch sind. Die alte Nexus-S 2.1 hat schneller umgeschaltet (bilde ich mir zumindest ein) und es bilden sich beim Umschalten mit der neuen Karte Artefakte bzw. das Bild stottert kurz. Das kann jedoch auch am nun aktivierten VDPAU hängen. Wie dem auch sei, das ist für eine Beta Version für mich vollkommen akzeptabel. Ausserdem ist meine Freundin genauso interessiert am Thema HDTV. Bald gibts Tatort in HD (sobald die den in HD produzieren, anfangs wird sicher nur hochgerechnet).

     

    Wo die CPU vorher bei ARD DVB-S mit ca. 20-25% pro Kern ausgelastet war komme mein System nun gerade einmal auf ca 3-7% pro Kern. Das steigt auch bei HD Fernsehen nur geringfügig an, zumindest was ich bisher testen konnte.